Commit f7168f0e authored by Florian Hölzl's avatar Florian Hölzl

some more plugin configurations and setup

parent 81d7c442
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="generated-src"/>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="generated-src"/>
<classpathentry kind="output" path="build"/>
</classpath>
......@@ -20,6 +20,11 @@
<arguments>
</arguments>
</buildCommand>
<buildCommand>
<name>edu.tum.cs.ccsm.dev_tools.gen_src.RemoveWarningsBuilder</name>
<arguments>
</arguments>
</buildCommand>
</buildSpec>
<natures>
<nature>org.eclipse.pde.PluginNature</nature>
......
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: AF3 Project Core
Bundle-SymbolicName: org.fortiss.af3.project
Bundle-Version: 1.0.0.qualifier
Bundle-Activator: org.fortiss.af3.project.AF3ProjectActivator
Bundle-Vendor: fortiss
Require-Bundle: org.fortiss.tooling.kernel;bundle-version="1.0.0";visibility:=reexport
Bundle-Name: %pluginName
Bundle-SymbolicName: org.fortiss.af3.project;singleton:=true
Bundle-Version: 1.0.0
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.fortiss.af3.project.model,
org.fortiss.af3.project.model.impl,
org.fortiss.af3.project.model.util
Require-Bundle: org.fortiss.tooling.kernel;bundle-version="1.0.0";visibility:=reexport
Bundle-ActivationPolicy: lazy
source.. = src/,\
generated-src/
# (c) 2011 ForTISS GmbH
bin.includes = .,\
model/,\
META-INF/,\
plugin.xml,\
plugin.properties
jars.compile.order = .
source.. = generated-src/,\
src/
output.. = build/
bin.includes = META-INF/,\
.
jre.compilation.profile = JavaSE-1.6
<?xml version="1.0" encoding="UTF-8"?>
<ecore:EPackage xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore" name="model"
nsURI="http://www.fortiss.org/af3/project" nsPrefix="org-fortiss-af3">
<eClassifiers xsi:type="ecore:EClass" name="Dummy"/>
</ecore:EPackage>
<?xml version="1.0" encoding="UTF-8"?>
<genmodel:GenModel xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI" xmlns:genmodel="http://www.eclipse.org/emf/2002/GenModel" copyrightText="(c) 2011 ForTISS GmbH"
modelDirectory="/org.fortiss.af3.project/generated-src" editDirectory="org.fortiss.af3.project.edit/src"
editorDirectory="/org.fortiss.af3.project.editor/src" modelPluginID="org.fortiss.af3.project"
modelName="Model" modelPluginClass="" editPluginClass="org.fortiss.af3.project.model.provider.ModelEditPlugin"
editorPluginClass="org.fortiss.af3.project.model.presentation.ModelEditorPlugin"
testsDirectory="/org.fortiss.af3.project.tests/test-src" importerID="org.eclipse.emf.importer.ecore"
arrayAccessors="true" complianceLevel="5.0" copyrightFields="false">
<foreignModel>project.ecore</foreignModel>
<genPackages prefix="AF3Project" basePackage="org.fortiss.af3.project" disposableProviderFactory="true"
ecorePackage="project.ecore#/"/>
</genmodel:GenModel>
# (c) 2011 ForTISS GmbH
pluginName = AF3 Project
providerName = www.fortiss.org
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.0"?>
<!--
(c) 2011 ForTISS GmbH
-->
<plugin>
<extension point="org.eclipse.emf.ecore.generated_package">
<package
uri="http://www.fortiss.org/af3/project"
class="org.fortiss.af3.project.model.AF3ProjectPackage"
genModel="model/project.genmodel"/>
</extension>
</plugin>
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment